Como resolver erro no wordpress “Warning: Parameter 1 to fdl_the_content() expected to be a reference …”

Quem visitou o blog do sucesso nesses últimos dias deve ter reparado na seguinte mensagem de erro: “Warning: Parameter 1 to fdl_the_content() expected to be a reference, value given in /home/…/public_html/…/wp-includes/plugin.php on line 170”

Divi WordPress Theme

Ou seja, em vez do conteúdo dos posts era exibida apenas essa mensagem.

Apenas hoje detetei o erro, o qual também já me havia ocorrido há uns tempos em um outro blog, e verifiquei que o erro estava a ser causado pelo plugin “Feed Layout” – que serve para exibir publicidade aos leitores do blog por email.

Se você também usa esse plugin, mais cedo ou mais tarde esse erro poderá ocorrer, mas nada de entrar em stress uma vez que a resolução do problema é bem simples.

 

Como resolver esse erro?

Para resolver esse problema apenas terá que editar o plugin “Feed Layout”.

Vá a “Plugins Instalados”, e no plugin “Feed Layout” clique em “Editar”.

erro do plugin feed layout

Desça até à linha 38 do código: O código exibido na linha 38 é:

function fdl_the_content(&$content)

Substitua essa linha de código por:

function fdl_the_content($content)

Como pode verificar apenas tem que eliminar o “&”.

 

E pronto, é bem simples e o problema fica imediatamente resolvido.

Author: Carlos Vieira

Empreendedor Digital

Share This Post On

1 Comment

  1. obrigada pela ajuda

Submit a Comment

O seu endereço de email não será publicado. Campos obrigatórios marcados com *